Установка vSphere Client 5.0 на Windows 8.1

К моему удивлению, попытка установить vSphere Client версии 5.0 на Windows 8.1 не увенчалась успехом.

This product can only be installed on Windows XP SP2 and above.

vsphere client error

На версию в заголовке не смотрите, ошибка звучит точно так же.

Решение лежало на поверхности — необходимо запустить установку клиента в режиме совместимости с Windows 7. Но не тут-то было, инсталлятор после указания имени пользователя и названия организации успешно вылетал без установки клиента…

Гугл подсказал, что это из-за отсутствия Net Framework 3.5 на системе. Родной инсталлятор как бы есть, но на Windows 8.1 он не запускается.

Решение по включению Net Framework любезно предоставлено Microsoft:

  • Если дистрибутив Windows под рукой, Dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:E:sourcessxs /LimitAccess
  • Если дистрибутива нет, заходите в Control Panel и выбираете пункт «Добавить/удалить опции Windows (features)

control panel

windows features

 

И устанавливаете Framework, скачивая его из интернета.

Также наблюдаются проблемы и с работой клиента, связано это с тем, что под Windows 8.1 нормально работает только клиент VMware-viclient-all-5.0.0-913577.exe и выше. К счастью, его можно скачать и без наличия лицензий, попросив скачать vSphere Hypervisov 5.5 и раскрыв внизу список Version History — VMware vSphere Hypervisor 5.0 Update 3. Скорее всего, все озвученные проблемы в свежей версии клиента сняты.

P.S. Подозреваю, что такая проблема есть и с другими «несвежими» версиями клиентов под 5.1 и 5.5.

2 комментария к “Установка vSphere Client 5.0 на Windows 8.1”

  1. С похожей проблемой столкнулись сразу после выхода Windows 8. В клиенте vSphere Client консоль ВМ показывала черный экран. В итоге, единственным приемлемым решением на тот момент было подключение к ВМ с помощью VMware Workstation.

Оставьте комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *